Tserver does not start on Ubuntu 18.04

I follow the following instructions:

wget https://downloads.yugabyte.com/yugabyte-2.0.0.0-linux.tar.gz
tar xvfz yugabyte-2.0.0.0-linux.tar.gz && cd yugabyte-2.0.0.0/
./bin/post_install.sh
./bin/yb-ctl create

:heavy_check_mark: 09/24 02:55:05 victor-u64 ~/tools/yugabyte ➜ bin/yb-ctl create
Creating cluster.
Waiting for cluster to be ready.
Viewing file /home/victor/yugabyte-data/node-1/disk-1/tserver.err:
In YugaByte DB, setting LC_COLLATE to C and all other locale settings to en_US.UTF-8 by default. Locale support will be enhanced as part of addressing https://github.com/YugaByte/yugabyte-db/issues/1557initdb: invalid locale name “en_US.UTF-8”
Viewing file /tmp/tmp0AVGiB:
2019-09-24 02:55:12,857 INFO: Starting master-1 with:
/home/victor/tools/software/yugabyte-2.0.0.0/bin/yb-master --fs_data_dirs “/home/victor/yugabyte-data/node-1/disk-1” --webserver_interface 127.0.0.1 --rpc_bind_addresses 127.0.0.1 --v 0 --version_file_json_path=/home/victor/tools/software/yugabyte-2.0.0.0 --webserver_doc_root “/home/victor/tools/software/yugabyte-2.0.0.0/www” --replication_factor=1 --yb_num_shards_per_tserver 2 --ysql_num_shards_per_tserver=2 --master_addresses 127.0.0.1:7100 --use_initial_sys_catalog_snapshot >"/home/victor/yugabyte-data/node-1/disk-1/master.out" 2>"/home/victor/yugabyte-data/node-1/disk-1/master.err" &
2019-09-24 02:55:12,869 INFO: Starting tserver-1 with:
/home/victor/tools/software/yugabyte-2.0.0.0/bin/yb-tserver --fs_data_dirs “/home/victor/yugabyte-data/node-1/disk-1” --webserver_interface 127.0.0.1 --rpc_bind_addresses 127.0.0.1 --v 0 --version_file_json_path=/home/victor/tools/software/yugabyte-2.0.0.0 --webserver_doc_root “/home/victor/tools/software/yugabyte-2.0.0.0/www” --tserver_master_addrs=127.0.0.1:7100 --yb_num_shards_per_tserver=2 --redis_proxy_bind_address=127.0.0.1:6379 --cql_proxy_bind_address=127.0.0.1:9042 --local_ip_for_outbound_sockets=127.0.0.1 --use_cassandra_authentication=false --ysql_num_shards_per_tserver=2 --start_pgsql_proxy --pgsql_proxy_bind_address=127.0.0.1:5433 >"/home/victor/yugabyte-data/node-1/disk-1/tserver.out" 2>"/home/victor/yugabyte-data/node-1/disk-1/tserver.err" &
2019-09-24 02:55:12,871 INFO: Waiting for master and tserver processes to come up.
2019-09-24 02:55:12,894 INFO: Waiting for master leader election and tablet server registration.
2019-09-24 02:55:14,095 INFO: PIDs found: {‘tserver’: [None], ‘master’: [67875]}
2019-09-24 02:55:14,096 ERROR: At least one master or tserver process is down.
^^^ Encountered errors ^^^

The log:
In YugaByte DB, setting LC_COLLATE to C and all other locale settings to en_US.UTF-8 by default. Locale support will be enhanced as part of addressing https://github.com/YugaByte/yugabyte-db/issues/1557initdb: invalid locale name “en_US.UTF-8”

How could I fix it?

Hi @victorspivak,

I don’t think the issue is with the locale name, thats just a warning. The real issue seems to be that not all processes are up:

2019-09-24 02:55:14,096 ERROR: At least one master or tserver process is down.
^^^ Encountered errors ^^^

Could you please post the output of ./bin/yb-ctl status?

I did not expect that I will get a reply after 2 weeks. It looks like the yugabyte community is very passive :frowning:

Based on your suggestion, I ignored the locale error (it was confusing) and found the problem - I have running the redis server and it uses the same port that yugabyte. I stopped the redis and cluster started w/o problems.

Thank you for your help
Victor

Hi @victorspivak,

Please accept our sincerest apologies :frowning_face::frowning_face:. We are usually very responsive, and are a very active community. Somehow this fell through the cracks. @dorian_yugabyte has just joined the team to make sure we don’t have such gaps going forward.

I am happy to hear you were able to get going with YugabyteDB. Is there anything else we can do to help with your use case (we’ll definitely try to respond quickly this time!) Also - you can get more realtime answers in our community slack channel.

I tried to join slack and I got:

This invite link is no longer active.

I try to run ./bin/ysqlsh but I am getting: Password for user yugabyte:
I could not find a default password in your documentation.

I was going to evaluate yugabyte vs. cockroachdb for our use cases. It looks like that cockroachdb is much more mature.

hi @victorspivak:

I tried www.yugabyte.com/slack link and it seems to be working fine. Can you share what link you tried? Will ask internally as well to see if anyone is aware of the problem.

Sorry about the Slack link — something must be amiss. The password was added yesterday for the yugabyte user. And it’s “yugabyte”.

Steve

On the https://docs.yugabyte.com/ page on the right top I click Join us on slack. The link is https://www.yugabyte.com/slack

If you are enabling auth, we had an issue in the 2.0.0 release, that has been addressed in the 2.0.1 release.

And as @stevebang said, the username/password is yugabyte/yugabyte

For example:

wget https://downloads.yugabyte.com/yugabyte-2.0.1.0-linux.tar.gz
tar xvf yugabyte-2.0.1.0-linux.tar.gz
cd yugabyte-2.0.1.0
./bin/post_install.sh

and then:

# clean slate:
$ ./bin/yb-ctl destroy
Destroying cluster.

# create a cluster with auth enabled:
$ ~/yugabyte-2.0.1.0/bin/yb-ctl start --tserver_flags="ysql_enable_auth=true"
Creating cluster.
Waiting for cluster to be ready.
----------------------------------------------------------------------------------------------------
| Node Count: 1 | Replication Factor: 1                                                            |
----------------------------------------------------------------------------------------------------
| JDBC                : jdbc:postgresql://127.0.0.1:5433/postgres                                  |
| YSQL Shell          : bin/ysqlsh                                                                 |
| YCQL Shell          : bin/cqlsh                                                                  |
| YEDIS Shell         : bin/redis-cli                                                              |
| Web UI              : http://127.0.0.1:7000/                                                     |
| Cluster Data        : /home/centos/yugabyte-data                                                 |
----------------------------------------------------------------------------------------------------

For more info, please use: yb-ctl status

$ ~/yugabyte-2.0.1.0/bin/ysqlsh -U yugabyte
Password for user yugabyte:
ysqlsh (11.2-YB-2.0.1.0-b0)
Type "help" for help.

yugabyte=# \d
Did not find any relations.
yugabyte=# create table t(n int);
CREATE TABLE
yugabyte=# select * from t;
 n
---
(0 rows)

yugabyte=#

Regarding the slack link, when I click that, I get:

Are you not getting the same?

I got the same error on my ubuntu 18.04 - BTW, I could access other slack channels on my ubuntu. When I tried your link from windows everything was fine and I was able to connect. I’ve joined the slack channel. Weird behavior.

I have created cluster using:
./bin/yb-ctl --rf 3 create --tserver_flags=“ysql_enable_auth=true”

./bin/yb-ctl status

| Node Count: 3 | Replication Factor: 3 |

| JDBC : jdbc:postgresql://127.0.0.1:5433/postgres |
| YSQL Shell : bin/ysqlsh |
| YCQL Shell : bin/cqlsh |
| YEDIS Shell : bin/redis-cli |
| Web UI : http://127.0.0.1:7000/ |

Cluster Data : /home/victor/yugabyte-data

Node 1: yb-tserver (pid 96385), yb-master (pid 96376)
JDBC : jdbc:postgresql://127.0.0.1:5433/postgres
YSQL Shell : bin/ysqlsh
YCQL Shell : bin/cqlsh
YEDIS Shell : bin/redis-cli
data-dir[0] : /home/victor/yugabyte-data/node-1/disk-1/yb-data
yb-tserver Logs : /home/victor/yugabyte-data/node-1/disk-1/yb-data/tserver/logs
yb-master Logs : /home/victor/yugabyte-data/node-1/disk-1/yb-data/master/logs


Node 2: yb-tserver (pid 96388), yb-master (pid 96379)
JDBC : jdbc:postgresql://127.0.0.2:5433/postgres
YSQL Shell : bin/ysqlsh -h 127.0.0.2
YCQL Shell : bin/cqlsh 127.0.0.2
YEDIS Shell : bin/redis-cli -h 127.0.0.2
data-dir[0] : /home/victor/yugabyte-data/node-2/disk-1/yb-data
yb-tserver Logs : /home/victor/yugabyte-data/node-2/disk-1/yb-data/tserver/logs
yb-master Logs : /home/victor/yugabyte-data/node-2/disk-1/yb-data/master/logs


Node 3: yb-tserver (pid 96396), yb-master (pid 96382)
JDBC : jdbc:postgresql://127.0.0.3:5433/postgres
YSQL Shell : bin/ysqlsh -h 127.0.0.3
YCQL Shell : bin/cqlsh 127.0.0.3
YEDIS Shell : bin/redis-cli -h 127.0.0.3
data-dir[0] : /home/victor/yugabyte-data/node-3/disk-1/yb-data
yb-tserver Logs : /home/victor/yugabyte-data/node-3/disk-1/yb-data/tserver/logs
yb-master Logs : /home/victor/yugabyte-data/node-3/disk-1/yb-data/master/logs

run: bin/ysqlsh -> asks password and yugabyte does not accepted
when i run bin/ysqlsh -h 127.0.0.2 i was able to login

There is now a note on the ysqlsh CLI page (https://docs.yugabyte.com/latest/admin/ysqlsh/) mentioning the new change.

Steve

@victorspivak looks like you are using the 2.0.0 release and not the 2.0.1 release. for the 2.0.0 release, the behavior you are seeing is exactly the reason why we had to add a default password for the default yugabyte user in the 2.0.1 release. The github issue #2465 captures the issue in 2.0.0.

  • for your current 2.0.0 cluster you can either set a password for yugabyte user (by starting cluster without flag first, setting a password and then re-starting with flag) or simply start the cluster without the --tserver_flags=“ysql_enable_auth=true” setting which will remove the password prompt everywhere.
  • OR you can start using the 2.0.1 release by wget https://downloads.yugabyte.com/yugabyte-2.0.1.0-linux.tar.gz where the default password will be used whenever you use the ysql_enable_auth flag.

pls accept our sincere apologies for the issues you faced, we will strive to do better here on.