How to show real IP instead of ‘localhost’ in Web UI and How to restart

Hi guys,

I’m trying to deploy a 6-node universe in my local server, and I followed the doc without all the AWS parameters.

It worked, but in the Web UI it shows localhost:7000 which I thought it should be like, the real IP instead of localhost.

And one more question:
If I reboot my server, how can I restart the YB-Master and YB-TServer on it?


Hello @Kai, it would be helpful if you could share the command lines for both master and tserver that you used to perform the manual deployment.

hi @sanketh , thank you for your reply. I used configuration file to create masters and tservers.

  • YB-Master

Command is the same as described in Start YB-Masters

./bin/yb-master --flagfile master.conf >& /home/centos/disk1/yb-master.out &

And the master.conf:

  • YB-TServer

Command is also from Start YB- TServers

./bin/yb-tserver --flagfile tserver.conf >& /home/centos/disk1/yb-tserver.out &

And the tserver.conf:


Relative to the USER GUIDES, I just modified the IP and remove the placement part for I didn’;t use the AWS.

hi @Kai:

Can you try setting this argument to corresponding IP (no port needed)


for each yb-master and yb-tserver?

That’s no different than starting the yb-master/yb-tserver processes for the first time. [Usually, you want to have some cron for this or convert this to a systemd type service that automatically restarts the process at startup.]

Thank you @kannan, it solved all my problems. Thank you so muck.