How to fully remove Yugabyted from Ubuntu?

I am running Ubuntu 22.04 server and initially installed Yugabyte 2.21.0.1-b1-linux-x86_64. I tried to delete the directories ~/var… and the Yugabyte program files and reinstall Yugabyte 2.20.4.0.

The problem is that I am using an application that keeps throwing this error, even after a fresh install:

Error connecting to Yugabyte database: cannot create schema: ERROR: Table system.transactions not found: OBJECT_NOT_FOUND (SQLSTATE XX000)

The application I use works well on a different Ubuntu 22.04 server, but I can’t seem to get Yugabyte to work on this particular server even though the two servers are almost identical.

The status looks fine:
yugabyted |
±---------------------------------------------------------------------------------------------------------+
| Status : Running. |
| Replication Factor : 1

I would love to reset this with whatever the standard Yugabyte default are in terms of tables. Or figure out how to reinstall with a default installation.

Thank you!

Hi @stuberman

You can do yugabyted destroy and then start a new one. Does that work?

Excuse my ignorance, does the local Yugabyted download include a basic schema (system.transactions)? I tried ‘destroy’ and did that remove that as well? It seems that I now get errors trying to use the UI dashboard showing no YSQL databases. Is there a command to create the basic (original) tables that a new vanilla install includes?

No. The download only includes the software, no data.

Destroy removes all data/schemas that were previously created.

You have to do yugabyted start again to install a new cluster.

1 Like