NOT able to connect with Keyspace

I am running YugaByte in K8 .
Machine : windows 10 x64
I have followed Quick Guide.

kubectl get services

kubernetes ClusterIP 443/TCP 2d2h
yb-db-service LoadBalancer 9000:30909/TCP,9042:30935/TCP,6379:30582/TCP,5433:31305/TCP 2d2h
yb-master-ui LoadBalancer 7000:30004/TCP 2d2h
yb-masters ClusterIP None 7000/TCP,7100/TCP 2d2h
yb-tservers ClusterIP None 9000/TCP,9100/TCP,9042/TCP,6379/TCP,5433/TCP

After that I inserted sample data using ysqlsh [keyspace created is debashish] that are provided in quick guide and fairly able to fetch data.

The second way I tried to create sample data by using c#.
HOST_IP : “”
PORT : 30935
I am able to connect and create keyspaces and get data from it. uprofile is the keyspace created

I am not able to connect to keyspace debashish using c# app

I have installed YugaByte in Docker too in the same system.
I tried to connect to the DB using the same IP & PORT which I used in c# app.
it fails.
ERROR : Connection error: (‘Unable to connect to any servers’, {‘’: error(113, “Tried connecting to [(‘’, 30935)]. Last error: No route to host”)})

The ysqlsh CLI connects on port 5433 (31305). That is the Postgres-compatible database API called YSQL. Your first application was connecting to the Cassandra-compatible API called YCQL on port 9042 (30935). In your screenshot, the tables that have a YSQL oid (Postgres table object id from pgclass) belong to the YSQL database debashish. If you switch your application to port 5433 (31305), you will be able to connect.
As for your second issue, that appears to be a network configuration issue unrelated to the database. Check your Docker network configuration to make sure that it is bridged to the network for your application.

Hope this helps.

Hi @Alan_Caldera ,
Thanks for your reply.
I tried to change the port in my c# app to connect with debashish keyspace .
I am getting ERROR : NoHostAvailableException
its throwing execption while creating the session.

Second issue :
I have managed to connect to azure cosmos from that container. using cqlsh.Any other input if you could provide would be helpful.

Can you please provide the ip+port that you’re connecting to ?
Are you able to access :7000 on the same ip ? Can you ping the same ip ?
Note that YSQL & YCQL are not compatible with each other.

The NoHostAvailableException error is a common one where the client can’t connect to the server.
In this case you either are using the wrong ip/port, or the db isn’t permitted to accept connections.


Please Note : I have redeployed cluster thats why a bit changes in IP and ports

On yb-db-service, do you eventually get an EXTERNAL-IP ? Which is pending ?
That is a load-balancer in front of YugabyteDB which you’ll be able to connect from outside.

Thats is what I did from c# application . Able to connect from c# app to correct keyspace but unable to connect using cqlsh . I am not sure why its showing still pending . But I am connecting to the telnet IP I showed. – ISSUE #2 of my post.

And regarding Issue #1 I was trying to connect ysql keyspaces using cqlsh which I got to know from @Alan_Caldera 's reply. So this is resolved as its not possible anyway to connect ysql keyspaces from cqlsh.

@Alan_Caldera @dorian_yugabyte,
I am able to resolve it.ISSUE #2
Had to delete ~/.cassandra
Solution Here